Friday, 18 May 2012

Your Project contains error(s), please fix them before running your application

Steps to reproduce the Issue
Step 1: Create any default project.
Step 2: Build it.
Step 3: Run(CTRL+f11) in Eclipse.

Bingoo... You got the bug...

Solution
This issue is mainly due to the mismatch between your ADT and SDKTool selection.(That You have Update)

Please follow the following combination..

           Latest by April 2012
  • Java 1.6 or higher is required for ADT 18.0.0.
  • Eclipse Helios (Version 3.6.2) or higher is required for ADT 18.0.0.
  • ADT 18.0.0 is designed for use with SDK Tools r18. If you haven't already installed SDK Tools r18 into your SDK, use the Android SDK Manager to do so..
        If you think this combination is older than the current you can always find the correct combination
        here.

2 comments:

  1. mostly this is the rezone

    debug.keystore expired
    check this link

    http://stackoverflow.com/questions/4954316/your-project-contains-errors-please-fix-it-before-running-it

    ReplyDelete
    Replies
    1. Hi krishnachary,

      The issue you have mentioned is different than I have mentioned.

      Please follow the following issue discussed here.

      http://stackoverflow.com/questions/2194808/debug-certificate-expired-error-in-eclipse-android-plugins

      Thanks,
      Ajay

      Delete